• 1 BookmarksBookmarks
  • 48 RepliesReplies
  • 19112 ReadTimes Read
  • 56 PointsPoints

Topic: Tiny Comments System 1.0

Usuario: manix
Rango: User Extremo
Mensajes: 437
Points: 214
Perfil: View Profile
Pais:
cr
Re:Tiny Comments System 1.0
Reply #15 February 28, 2013 - 01:42 01:42
A mi no me sale nada en los temas cuando lo instalo, no se me muestran las respuestas como se muestra en las imagenes del modulo, hay que hacer algo mas despues de instalarlo, le di los permisos a los usuarios, a los foros y todos permanece igual como si no se huviese instalado...

Creo que tari lo ha dejado para que no pueda comentar el post inicial, unicamente se pueden comentar las respuestas

Tags for this topic:

Usuario: manix
Rango: User Extremo
Mensajes: 437
Points: 214
Perfil: View Profile
Pais:
cr
Re:Tiny Comments System 1.0
Reply #16 February 28, 2013 - 01:44 01:44
Perdon 4k!
Tal ves la confucion al usuario se la cause yo al reportar esto aca. Quisas deberia haberlo hecho en otro lado.

No importa, cada comentario/sugerencia acá es para mejoras. En todo caso, esperaré a tari a que revise los archivos php, porque yo he revisado los eventos que enlazan los comentarios y parece que el error no sucede alli.

Usuario: ^HeRaCLeS^
Rango: Excelente User
Mensajes: 265
Points: 100
Mi web: http://www.smfpersonal.net
Perfil: View Profile
Pais:
ar
Re:Tiny Comments System 1.0
Reply #17 February 28, 2013 - 02:01 02:01
Justo estabamos hablando por skype sobre esto con 4k.

El problema esta solo con este icono
Code: [Select]
;)
Yo no se nada de ajax por lo tanto no puedo aportar una posible solucion. Pero pareciera que el error biene del parseo en los iconos en el ajax, porque los datos en la base los guarda bien. Por eso al actualizar me muestra bien el mensaje.

Mirando con firebug:
El html me lo muestra asi:

Code: [Select]
<div class="body">null</div>
Y la consola me devuelve esto:

Code: [Select]
{"body":null,"id":19,"avatar":"<img class=\"avatar\" src=\"http:\/\/www.itabajozero.com.ar\/NewMods\/avatars\/Actors\/David_Boreanaz.jpg\" alt=\"\" \/>","group_color":"style=\"color:#FF0000;\"","member_name":"^HeRaCLeS^","member_id":"1","date":"<strong>Hoy<\/strong> a las 03:25:39 am","delete_url":"<a href=\"#\" class=\"delete_comment\" name=\"19\">Eliminar<\/a>","error":""}

Muchos mas datos que esos no puedo aportar.

Solo un dato mas, si desactivo los iconos en la administracion del mod el mensaje me lo muestra bien sin tener que actualizar.

Saludos

no avatar
Usuario: cryber
Rango: Nuevo Usuario
Mensajes: 21
Points: 1
Mi web: http://www.cryber.com/foro/
Perfil: View Profile
Re:Tiny Comments System 1.0
Reply #18 February 28, 2013 - 03:09 03:09
Instalado y funcionando perfectamente. Buen curro!! :) en mi caso incluido el icono
Code: [Select]
;) lo traduce perfectamente a ;)

Perdonad, donde sería el soporte..parece que es incompatible con el mini mod Likes Comments, éste ha dejado de funcionar

Usuario: Lean
Rango: Fundador
Mensajes: 6782
Points: 236
Perfil: View Profile
Pais:
ar
Re:Tiny Comments System 1.0
Reply #19 February 28, 2013 - 06:03 06:03
A mi no me sale nada en los temas cuando lo instalo, no se me muestran las respuestas como se muestra en las imagenes del modulo, hay que hacer algo mas despues de instalarlo, le di los permisos a los usuarios, a los foros y todos permanece igual como si no se huviese instalado...
De nada, gracias por tu comentario de aliento hacia el trabajo de horas y horas! :X

Usuario: manix
Rango: User Extremo
Mensajes: 437
Points: 214
Perfil: View Profile
Pais:
cr
Tiny Comments System 1.0
Reply #20 February 28, 2013 - 08:04 08:04
Instalado y funcionando perfectamente. Buen curro!! :) en mi caso incluido el icono
Code: [Select]
;) lo traduce perfectamente a ;)

Perdonad, donde sería el soporte..parece que es incompatible con el mini mod Likes Comments, éste ha dejado de funcionar

Ahora lo mejor es que hagas un tópico nuevo en el área de soporte general


Enviado desde mi iPhone con Tapatalk

no avatar
Usuario: cryber
Rango: Nuevo Usuario
Mensajes: 21
Points: 1
Mi web: http://www.cryber.com/foro/
Perfil: View Profile
Re: Tiny Comments System 1.0
Reply #21 February 28, 2013 - 08:55 08:55
Okis. Gracias



_______________________
Cryber dando vueltas por el mundo, con su S Advance y Android

Usuario: manix
Rango: User Extremo
Mensajes: 437
Points: 214
Perfil: View Profile
Pais:
cr
Re:Tiny Comments System 1.0
Reply #22 February 28, 2013 - 10:47 10:47
Justo estabamos hablando por skype sobre esto con 4k.

El problema esta solo con este icono
Code: [Select]
;)
Yo no se nada de ajax por lo tanto no puedo aportar una posible solucion. Pero pareciera que el error biene del parseo en los iconos en el ajax, porque los datos en la base los guarda bien. Por eso al actualizar me muestra bien el mensaje.

Mirando con firebug:
El html me lo muestra asi:

Code: [Select]
<div class="body">null</div>
Y la consola me devuelve esto:

Code: [Select]
{"body":null,"id":19,"avatar":"<img class=\"avatar\" src=\"http:\/\/www.itabajozero.com.ar\/NewMods\/avatars\/Actors\/David_Boreanaz.jpg\" alt=\"\" \/>","group_color":"style=\"color:#FF0000;\"","member_name":"^HeRaCLeS^","member_id":"1","date":"<strong>Hoy<\/strong> a las 03:25:39 am","delete_url":"<a href=\"#\" class=\"delete_comment\" name=\"19\">Eliminar<\/a>","error":""}

Muchos mas datos que esos no puedo aportar.

Solo un dato mas, si desactivo los iconos en la administracion del mod el mensaje me lo muestra bien sin tener que actualizar.

Saludos

El error recaé del lado del servidor, eso es seguro. Inicialmente se podría revisar que:
- smf esté llamando alguna función que crea que se está tratando de insertar texto malicioso
- se esté escapando (escape) algun caracter
- el formato de la base de datos esté incorrecta (colación)
- a nivel de php algunas veces hay opciones habilitadas que no debería estar, por ejemplo: magic_quotes_gpc

Usuario: ^HeRaCLeS^
Rango: Excelente User
Mensajes: 265
Points: 100
Mi web: http://www.smfpersonal.net
Perfil: View Profile
Pais:
ar
Re:Tiny Comments System 1.0
Reply #23 February 28, 2013 - 11:18 11:18
El php y la base estan parseando bien, ya que los datos son bien guardados y luego de actualizar muestra bien el contenido.

Esperemos que esto sea algo que solo me pase a mi.

Por lo pronto creo que a ningun otro le paso esto.

Usuario: manix
Rango: User Extremo
Mensajes: 437
Points: 214
Perfil: View Profile
Pais:
cr
Re:Tiny Comments System 1.0
Reply #24 February 28, 2013 - 11:55 11:55
Es que quiero saber la razón aunque te pase solo a vos. No creo en la teoría espontánea en estos escenarios. Algo pasa.

Si no es mucho perdirte Heracles, ¿es posible que puedas debugger haciendo "echos" en la función insertComment del archivo /Sources/Comments.php?

Usuario: ^HeRaCLeS^
Rango: Excelente User
Mensajes: 265
Points: 100
Mi web: http://www.smfpersonal.net
Perfil: View Profile
Pais:
ar
Re:Tiny Comments System 1.0
Reply #25 February 28, 2013 - 05:21 17:21
No hay problema manix, solo que lo hare por la noche porque ahora ando corto de tiempo y tengo que instalalo nuevamente.
Todo lo que pueda hacer para mejorar la aplicacion lo hare :)

Usuario: manix
Rango: User Extremo
Mensajes: 437
Points: 214
Perfil: View Profile
Pais:
cr
Re:Tiny Comments System 1.0
Reply #26 February 28, 2013 - 05:40 17:40
No hay problema manix, solo que lo hare por la noche porque ahora ando corto de tiempo y tengo que instalalo nuevamente.
Todo lo que pueda hacer para mejorar la aplicacion lo hare :)
Te agradezco enormente.

Usuario: nikooo14
Rango: Excelente User
Mensajes: 235
Points: 122
Mi web: http://servidornolimit.net
Perfil: View Profile
Pais:
cl
Tiny Comments System 1.0
Reply #27 March 01, 2013 - 04:14 16:14
Tuve que sacarlo de mi foro, me daba unos 170 o 180 errores en el log, era algo de comments.english.php algo de los límites de caracteres( yo lo tenía en 0 )


Enviado desde mi iPhone usando tapatalk 2

Usuario: 4kstore
Rango: Administrador
Mensajes: 4899
Points: 8105
Mi web: http://www.smfsimple.com
Perfil: View Profile
Pais:
ar
Re:Tiny Comments System 1.0
Reply #28 March 01, 2013 - 06:27 18:27
Tuve que sacarlo de mi foro, me daba unos 170 o 180 errores en el log, era algo de comments.english.php algo de los límites de caracteres( yo lo tenía en 0 )


Enviado desde mi iPhone usando tapatalk 2

El paquete que subimos hace poco ya tenia reparado ese error, te comento por si te interesa tener esta funcionalidad en tu foro.
Saludos

Usuario: ^HeRaCLeS^
Rango: Excelente User
Mensajes: 265
Points: 100
Mi web: http://www.smfpersonal.net
Perfil: View Profile
Pais:
ar
Re:Tiny Comments System 1.0
Reply #29 March 02, 2013 - 01:01 01:01
manix Probe con todos los smileys y con el unico que pasa el error es con ;)

Ahora si imprimo $context['comment']['body'] antes de:

Code: [Select]
if (!empty($modSettings['tcs_smiles'])) //Parsing Smileys?
parsesmileys($context['comment']['body']);

Me devuelve el texto bien.

Si imprimo despues de ello me devuelve Null

En la consola me tira el error:
Quote
TypeError: msg is null
if (msg.error == ''){

comments.js  (línea 114)



 

TAGS



Topics Releated By Tags

Subject Replies
Mods SMFSimple Started by Lean 2 Replies
4436 Views
Mods SMFSimple Started by 4kstore 49 Replies
28790 Views
Mods SMFSimple Started by Lean 33 Replies
16163 Views
Mods SMFSimple Started by 4kstore 60 Replies
26396 Views
Mods SMFSimple Started by 4kstore 183 Replies
98895 Views
top

Smfsimple.com es un sitio destinado a brindar un servicio de soporte y herramientas para foros realizados con el sistema de foros gratuito simplemachines.org. Contamos con un selecto equipo de desarrolladores y conocedores del sistema, sus foros estaran en buenas manos.
This site is not affiliated with or endorsed by Simple Machines